re = /[\n](.*):\s(.*)-.*(👤|💂|👼|⚡️|🐶|🐺☃️|🌝🐺|🐺|💋|🕵️|🔥|👶|👁|😼|☮️|🖕|🔫|🔮|🎭|🧑🔬|🙇|🎯|🦅|🎖|🃏|🤕|🔪|👑|🧑|😈|👱🌚|👳|⚒|👷|🤯|💤|💘|🌀|📚|👨🔬)\s(.*)/m
str = 'بازیکن های زنده: 1 / 5
تست1: 💀 مرده - رمال 🦅 بازنده
تست2: فرار کرده - ریش سفید 📚 بازنده
تست3: 💀 مرده - شیمیدان 👨🔬 بازنده
تست4: 💀 مرده - پسر گیج 🤕 بازنده
تست5: 🙂 زنده - آتش زن 🔥 برنده
مدت زمان بازی: 00:05:31
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end