import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n](.*):\\s(.*)-.*(👤|💂|👼|⚡️|🐶|🐺☃️|🌝🐺|🐺|💋|🕵️|🔥|👶|👁|😼|☮️|🖕|🔫|🔮|🎭|🧑🔬|🙇|🎯|🦅|🎖|🃏|🤕|🔪|👑|🧑|😈|👱🌚|👳|⚒|👷|🤯|💤|💘|🌀|📚|👨🔬)\\s(.*)";
final String string = "بازیکن های زنده: 1 / 5\n"
+ "تست1: 💀 مرده - رمال 🦅 بازنده\n"
+ "تست2: فرار کرده - ریش سفید 📚 بازنده\n"
+ "تست3: 💀 مرده - شیمیدان 👨🔬 بازنده\n"
+ "تست4: 💀 مرده - پسر گیج 🤕 بازنده\n"
+ "تست5: 🙂 زنده - آتش زن 🔥 برنده\n\n\n"
+ "مدت زمان بازی: 00:05:31\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}