using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\A)\b(?=\p{Lu})";
string substitution = @"\n";
string input = @"Français Langues bantoues Presse écrite Gabon Particularité linguistique";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}