re = /(?!\A)\b(?=\p{Lu})/m
str = 'Français Langues bantoues Presse écrite Gabon Particularité linguistique'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result