import re
regex = re.compile(r"(?!\A)\b(?=\p{Lu})", flags=re.MULTILINE)
test_str = "Français Langues bantoues Presse écrite Gabon Particularité linguistique"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)