$re = '/(?!\A)\b(?=\p{Lu})/m';
$str = 'Français Langues bantoues Presse écrite Gabon Particularité linguistique';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;