# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)/$2/gm;t' <<< "0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
"