import re
regex = re.compile(r"\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)", flags=re.MULTILINE)
test_str = ("0.123456789\n"
"0.12345678\n"
"100\n"
"100.123\n"
"5.12457\n"
"5\n"
"5.1\n"
"abc\n"
"00.12345678\n")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)