import Foundation
let pattern = #"\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)