const regex = /\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(0\\.\\d{1,8}|\\d+(?!.)|(?!0)\\d+\\.\\d{1,8})\\b|([\\d\\w.]+)', 'gm')
const str = `0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);