use strict;
my $str = '0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
';
my $regex = qr/\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";