#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)"
Local $sString = "0.123456789" & @CRLF & _
"0.12345678" & @CRLF & _
"100" & @CRLF & _
"100.123" & @CRLF & _
"5.12457" & @CRLF & _
"5" & @CRLF & _
"5.1" & @CRLF & _
"abc" & @CRLF & _
"00.12345678" & @CRLF & _
""
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)