using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b|([\d\w.]+)";
string substitution = @"$2";
string input = @"0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}