using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"turned\s+into\s+a\s+democracy";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing turned into a democracy
elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned into
a democracy elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned into a
democracy elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned
into a
democracy elit, sed do eiusmod tempor incididunt ut labore";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}