package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)turned\s+into\s+a\s+democracy`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing turned into a democracy
elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned into
a democracy elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned into a
democracy elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned
into a
democracy elit, sed do eiusmod tempor incididunt ut labore`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}