import re
regex = re.compile(r"turned\s+into\s+a\s+democracy", flags=re.MULTILINE)
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing turned into a democracy \n"
"elit, sed do eiusmod tempor incididunt ut labore\n\n"
"Lorem ipsum dolor sit amet, consectetur adipiscing turned into \n"
"a democracy elit, sed do eiusmod tempor incididunt ut labore\n\n"
"Lorem ipsum dolor sit amet, consectetur adipiscing turned into a \n"
"democracy elit, sed do eiusmod tempor incididunt ut labore\n\n"
"Lorem ipsum dolor sit amet, consectetur adipiscing turned \n"
"into a \n"
"democracy elit, sed do eiusmod tempor incididunt ut labore")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")