import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "turned\\s+into\\s+a\\s+democracy";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing turned into a democracy \n"
+ "elit, sed do eiusmod tempor incididunt ut labore\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing turned into \n"
+ "a democracy elit, sed do eiusmod tempor incididunt ut labore\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing turned into a \n"
+ "democracy elit, sed do eiusmod tempor incididunt ut labore\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing turned \n"
+ "into a \n"
+ "democracy elit, sed do eiusmod tempor incididunt ut labore";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}