# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^\d*)\d{3}(?=\d{2,}$)/xxx-/gm;t' <<< "9871234567
98712345678
987123456789
9871234567890
abc 9871234567"