using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^\d*)\d{3}(?=\d{2,}$)";
string substitution = @"xxx-";
string input = @"9871234567
98712345678
987123456789
9871234567890
abc 9871234567";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}