$re = '/(?<=^\d*)\d{3}(?=\d{2,}$)/m';
$str = '9871234567
98712345678
987123456789
9871234567890
abc 9871234567';
$subst = "xxx-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;