const regex = /(?<=^\d*)\d{3}(?=\d{2,}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\d*)\\d{3}(?=\\d{2,}$)', 'gm')
const str = `9871234567
98712345678
987123456789
9871234567890
abc 9871234567`;
const subst = `xxx-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);