use strict;
my $str = '9871234567
98712345678
987123456789
9871234567890
abc 9871234567';
my $regex = qr/(?<=^\d*)\d{3}(?=\d{2,}$)/mp;
my $subst = 'xxx-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";