re = /(?<=^\d*)\d{3}(?=\d{2,}$)/m
str = '9871234567
98712345678
987123456789
9871234567890
abc 9871234567'
subst = 'xxx-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result