#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^\d*)\d{3}(?=\d{2,}$)"
Local $sString = "9871234567" & @CRLF & _
"98712345678" & @CRLF & _
"987123456789" & @CRLF & _
"9871234567890" & @CRLF & _
"" & @CRLF & _
"abc 9871234567"
Local $sSubst = "xxx-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)