#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\S+(?: ?\S+)*)\b"
Local $sString = "Disinfecting Wipes Lemon Fresh 35 pkg 3.39" & @CRLF & _
"Ultra Liquid Bleach Mountain Fresh 96 oz 2.39" & @CRLF & _
"FF & LS Broth Chicken 32 oz 2.99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")