// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(\S+(?: ?\S+)*)\b").unwrap();
let string = "Disinfecting Wipes Lemon Fresh 35 pkg 3.39
Ultra Liquid Bleach Mountain Fresh 96 oz 2.39
FF & LS Broth Chicken 32 oz 2.99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}