package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\S+(?: ?\S+)*)\b`)
var str = `Disinfecting Wipes Lemon Fresh 35 pkg 3.39
Ultra Liquid Bleach Mountain Fresh 96 oz 2.39
FF & LS Broth Chicken 32 oz 2.99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}