import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\S+(?: ?\\S+)*)\\b";
final String string = "Disinfecting Wipes Lemon Fresh 35 pkg 3.39\n"
+ "Ultra Liquid Bleach Mountain Fresh 96 oz 2.39\n"
+ "FF & LS Broth Chicken 32 oz 2.99";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}