re = /\b(\S+(?: ?\S+)*)\b/
str = 'Disinfecting Wipes Lemon Fresh 35 pkg 3.39
Ultra Liquid Bleach Mountain Fresh 96 oz 2.39
FF & LS Broth Chicken 32 oz 2.99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end