using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\S+(?: ?\S+)*)\b";
string input = @"Disinfecting Wipes Lemon Fresh 35 pkg 3.39
Ultra Liquid Bleach Mountain Fresh 96 oz 2.39
FF & LS Broth Chicken 32 oz 2.99";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}