#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iU)a[\s]+href="[^mailto][\S]+polskieszlaki\.pl(.*)(\?)(.*)\""
Local $sString = "<a href="http://www.polskieszlaki.pl" style="color: #09173b; text-decoration: none;"></a>" & @CRLF & _
"<a href="http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email" >" & @CRLF & _
"<a href="http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie">" & @CRLF & _
"<a href="http://www.polskieszlaki.pl/?asas">asaaS</a>" & @CRLF & _
"<a href="http://www.polskieszlaki.pl/wawel.htm">asaaS</a>" & @CRLF & _
"<a href="mailto:biuro@polskieszlaki.pl">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")