const regex = /a[\s]+href="[^mailto][\S]+polskieszlaki\.pl(.*)(\?)(.*)\"/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a[\\s]+href="[^mailto][\\S]+polskieszlaki\\.pl(.*)(\\?)(.*)\\"', 'ig')
const str = `<a href="http://www.polskieszlaki.pl" style="color: #09173b; text-decoration: none;"></a>
<a href="http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email" >
<a href="http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie">
<a href="http://www.polskieszlaki.pl/?asas">asaaS</a>
<a href="http://www.polskieszlaki.pl/wawel.htm">asaaS</a>
<a href="mailto:biuro@polskieszlaki.pl">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}