re = /a[\s]+href="[^mailto][\S]+polskieszlaki\.pl(.*)(\?)(.*)\"/i
str = '<a href="http://www.polskieszlaki.pl" style="color: #09173b; text-decoration: none;"></a>
<a href="http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email" >
<a href="http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie">
<a href="http://www.polskieszlaki.pl/?asas">asaaS</a>
<a href="http://www.polskieszlaki.pl/wawel.htm">asaaS</a>
<a href="mailto:biuro@polskieszlaki.pl">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end