import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a[\\s]+href=\"[^mailto][\\S]+polskieszlaki\\.pl(.*)(\\?)(.*)\\\"";
final String string = "<a href=\"http://www.polskieszlaki.pl\" style=\"color: #09173b; text-decoration: none;\"></a>\n"
+ "<a href=\"http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email\" >\n"
+ "<a href=\"http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie\">\n"
+ "<a href=\"http://www.polskieszlaki.pl/?asas\">asaaS</a>\n"
+ "<a href=\"http://www.polskieszlaki.pl/wawel.htm\">asaaS</a>\n"
+ "<a href=\"mailto:biuro@polskieszlaki.pl\">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}