use strict;
my $str = '<a href="http://www.polskieszlaki.pl" style="color: #09173b; text-decoration: none;"></a>
<a href="http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email" >
<a href="http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie">
<a href="http://www.polskieszlaki.pl/?asas">asaaS</a>
<a href="http://www.polskieszlaki.pl/wawel.htm">asaaS</a>
<a href="mailto:biuro@polskieszlaki.pl">
';
my $regex = qr/a[\s]+href="[^mailto][\S]+polskieszlaki\.pl(.*)(\?)(.*)\"/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}