import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"a[\s]+href="[^mailto][\S]+polskieszlaki\.pl(.*)(\?)(.*)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
<a href="http://www.polskieszlaki.pl" style="color: #09173b; text-decoration: none;"></a>
<a href="http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email" >
<a href="http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie">
<a href="http://www.polskieszlaki.pl/?asas">asaaS</a>
<a href="http://www.polskieszlaki.pl/wawel.htm">asaaS</a>
<a href="mailto:biuro@polskieszlaki.pl">
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)