using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a[\s]+href=""[^mailto][\S]+polskieszlaki\.pl(.*)(\?)(.*)\""";
string input = @"<a href=""http://www.polskieszlaki.pl"" style=""color: #09173b; text-decoration: none;""></a>
<a href=""http://www.polskieszlaki.local/wawel-w-krakowie.htm?utm_source=2017-06-13&utm_medium=email"" >
<a href=""http://www.polskieszlaki.pl/zamek-w-pszczynie.htm?utm_source=2017-06-13&utm_medium=email&utm_campaign=newslettery&utm_content=atrakcje-zamek-w-pszczynie"">
<a href=""http://www.polskieszlaki.pl/?asas"">asaaS</a>
<a href=""http://www.polskieszlaki.pl/wawel.htm"">asaaS</a>
<a href=""mailto:biuro@polskieszlaki.pl"">
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}