#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)"
Local $sString = "D-EBCB_Cessna_172-K" & @CRLF & _
"I-ZARY_Maule_MXT-7" & @CRLF & _
"I-ESML_Husky_A1" & @CRLF & _
"I-9865_P92_Echo_80CV" & @CRLF & _
"I-8982_P92_Echo_100CV" & @CRLF & _
"I-BLAE_PA28_Cadet" & @CRLF & _
"I-PIDR_PA28_Archer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")