const regex = /^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)', '')
const str = `D-EBCB_Cessna_172-K
I-ZARY_Maule_MXT-7
I-ESML_Husky_A1
I-9865_P92_Echo_80CV
I-8982_P92_Echo_100CV
I-BLAE_PA28_Cadet
I-PIDR_PA28_Archer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}