import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)";
final String string = "D-EBCB_Cessna_172-K\n"
+ "I-ZARY_Maule_MXT-7\n"
+ "I-ESML_Husky_A1\n"
+ "I-9865_P92_Echo_80CV\n"
+ "I-8982_P92_Echo_100CV\n"
+ "I-BLAE_PA28_Cadet\n"
+ "I-PIDR_PA28_Archer";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}