import re
regex = re.compile(r"^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)")
test_str = ("D-EBCB_Cessna_172-K\n"
"I-ZARY_Maule_MXT-7\n"
"I-ESML_Husky_A1\n"
"I-9865_P92_Echo_80CV\n"
"I-8982_P92_Echo_100CV\n"
"I-BLAE_PA28_Cadet\n"
"I-PIDR_PA28_Archer")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")