package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)`)
var str = `D-EBCB_Cessna_172-K
I-ZARY_Maule_MXT-7
I-ESML_Husky_A1
I-9865_P92_Echo_80CV
I-8982_P92_Echo_100CV
I-BLAE_PA28_Cadet
I-PIDR_PA28_Archer`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}