using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]-[A-Z0-9]{4})_([A-Za-z0-9]+(?:_)?(?:[A-Za-z0-9]+)_[A-Za-z0-9]+(?:-[A-Za-z0-9]*)?)";
string input = @"D-EBCB_Cessna_172-K
I-ZARY_Maule_MXT-7
I-ESML_Husky_A1
I-9865_P92_Echo_80CV
I-8982_P92_Echo_100CV
I-BLAE_PA28_Cadet
I-PIDR_PA28_Archer";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}