# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<.*?>)/<span>$1<\/span>/g;t' <<< "<div id=\"Content\">
<p>1</p>
<h2>1</h2>
<h2>2</h2>
</div>"