import re
regex = re.compile(r"(<.*?>)")
test_str = ("<div id=\"Content\">\n"
" <p>1</p>\n"
" <h2>1</h2>\n"
" <h2>2</h2>\n"
"</div>")
subst = "<span>$1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)