# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((frok |dork )*)(\w+) is (\d+) Foo//gm;t' <<< "frok dork dumb is 10 Foo
frok dork is 10 Foo"