$re = '/((frok |dork )*)(\w+) is (\d+) Foo/m';
$str = 'frok dork dumb is 10 Foo
frok dork is 10 Foo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;