re = /((frok |dork )*)(\w+) is (\d+) Foo/m
str = 'frok dork dumb is 10 Foo
frok dork is 10 Foo'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result