#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((frok |dork )*)(\w+) is (\d+) Foo"
Local $sString = "frok dork dumb is 10 Foo" & @CRLF & _
"frok dork is 10 Foo"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)