const regex = /((frok |dork )*)(\w+) is (\d+) Foo/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((frok |dork )*)(\\w+) is (\\d+) Foo', 'gm')
const str = `frok dork dumb is 10 Foo
frok dork is 10 Foo`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);